Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 11, 2026 - 17:00 CDT
Scheduled
PLOT will be updating our software.
Release Notes: - Paginating Submittals: Improved performance of the Procurement tool by paginating the loading of Submittals. - Schedule Reports: Introduced Scheduling of Procurement Dashboard reports (e.g. Imminent and Past Due Action, and A & Report). - DroneDeploy Integration Fix: Updated DroneDeploy API configuration due to some customers not seeing their imagery. - Other bugfixes and performance improvements.
Posted Mar 11, 2026 - 11:05 CDT
This scheduled maintenance affected: Web Application.